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Printing

All programmers hate writing printing routines.  We would love to put a big friendly 'Print" button somewhere which 
would just do the right thing when you click on it, and print out the document just as you want it.  The problem is that 
all printers are different, with different page sizes, different resolutions, different printable areas within the page, fonts, 
postscript support and so on.  The users themselves vary almost as much in their requirements, so to cope with all the 
variations we have to make everything variable, with lots of controls to set up to get the best out of each printer.  This 
makes life complicated for the user, and you are going to have to do a certain amount of experimentation to find the 
settings which best suit your printer and your tastes.  The object of this file is to guide you through this process.

The unregistered version of BarFly can print out the text of any window, and can print one tune (in staff notation) at a 
time.  When registered, it can print out any selection of tunes from a file consecutively, placing each tune below the 
previous one on the page and continuing for as many pages as necessary.  To print the text, issue the PrintÉ command 
while the window is in text mode; to print music, print from a window in split-screen mode.  To select multiple tunes 
for printing, either command-click on the tune names in the index pane, shift-click to select a range of tunes, or type 
command-option-A to select all tunes in the index.  The tunes will be printed in the order in which they are listed in 
the index, and can be ordered either by ID or alphabetically, using the Sort Index by> sub-menu under View.

THE EFFECT OF SCALE

Printing is WYSIWYG, and if you just use the default settings which come with the program you will get printed 
music which looks just like it does on the screen.  These settings are optimised to make the music readable on a 72 
dots per inch monitor, and if you are printing on an old imagewriter or other dot-matrix printer that's about the best 
that you can do.  Modern printers have much higher resolutions though, and can produce a much more finely-textured 
picture.  In order to take advantage of this it is necessary to draw the picture larger, and to then reduce the size to fit 
the printed page.

Here's a tune to work with:

X:1
T:Piper's Chair, The
T:Cathaoir an Ph\'iob\'aire
R:jig
D:Bobby Gardiner: His Master's Choice.
Z:id:hn-jig-4
M:6/8
K:G
DGG GFD|c2c cAc|ded cAG|FAG FEF|DGG GFD|c2c cAc|ded cAF|1 AGF G3:|2 AGF GBd||
|:~g3 agf|d2g gfg|GFG =fef|A2B cBA|GBd g2f|d2e fdc|Bdd cAF|1 AGF GBd:|2 AGF G3||

In the View menu, make sure that Antialias Music is off.  Go to the Viewer PreferencesÉ command in the Edit menu 
and make sure that "Use Printer Page Size" is selected, then switch to split-screen and take a look at the music.  It has 
been transcribed with eight bars to a line, and the notes are rather crowded together on screen.  Now go to the Page 
SetupÉ command.  Make sure that the correct paper size is selected,   and set the scale or magnification to 80%.  When 
you dismiss the dialog, the displayed music gets bigger, and if you have a small monitor, the right- hand end of the 
staff may not be visible.  Don't worry about it;  the program has enlarged the picture just enough so it fits into the 
printable area of your printer page, and as long as you have "Use Printer Page Size" selected it won't lose the right 
hand end of the staff.  Enlarging the picture on screen means that the staves have also moved further apart, so go back 
to the Viewer PreferencesÉ panel and increase the number of staves per page to move them back together.  You can 
check on the effect of changes which you make in here by using the Apply button without leaving the dialog.  Print off 
a copy with the PrintÉ command and see what it looks like.  Now go back to the Page SetupÉ command and decrease 
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the scale to 60%.  Again move the staves together and print another copy.

Compare the two printouts.  At the smaller scale the result is crisper and cleaner, but the staff and all the symbols on it 
are perhaps too small.  Go back to the Viewer Preferences and increase the staff height from 24 to 32 or 36.  (Staff 
height is always a multiple of 4.  If you enter a number which isn't a multiple of 4 the program will round it to the 
nearest.)  You may want to move the staves further apart again to allow for the greater staff height.  When you change 
the staff height, all of the symbols on it are resized, so that they retain their proportions.  Print again and see what that 
looks like.  You can see that the larger the program draws the music and the more it is reduced to fit the printer, the 
better the result.  Try setting the scale down to 20 or 25% (whatever is the smallest number your printer will accept).  
What will usually happen now is that the program will bleep at you and tell you that there's not enough memory for 
offscreen drawing.  Here you see the drawback of small scale percentages - you need increasing amounts of memory to 
draw the vast picture at its original size.  You can usually still print, though, even if you can't use offscreen drawing.

(If you really want the music printed smaller, so that it does not fill the width of the page, then you should select 
Custom Page Size in the Viewer Preferences.  If you now choose to set the printing scale smaller than 100%, the 
picture will not be enlarged;  instead the printed image will get smaller.)

SMOOTHING THE SYMBOLS

Antialiasing makes a big difference to the appearance of music on screen, and if your printer is capable of printing 
grayscale or colour can also improve printed music.   Set the scale back to 80% with the Page SetupÉ dialog,  turn 
offscreen drawing back on, and also turn on Antialias Music (both in the View menu).  Now try printing the picture 
with antialiasing.  If this improves printed output and your machine has plenty of RAM, you may want to quit and 
increase the program's memory partition using the Finder's Get Info command.   Explore the printer's options in the 
Page Setup and Print dialogs.  If your printer offers "Graphics Smoothing" or "Enhanced Resolution", try that instead 
of antialiasing;  you may find the effect preferable.

PRINTING TUNE BOOKS

The registered version of BarFly can print a whole file of tunes at once.   You have independant control of margins 
and page numbering, and you can also print on both sides of the paper.

Before you start
There are a number of things to check before attempting to print a large tune book.  Failure to do so may result in 
much wasted paper and a frayed temper!

¥       Use the Check all Tunes command from the Edit menu, and fix any errors that it reports.  There's no point in 
printing garbage, and worse, if there is a tune with a serious error in it half way through the file it may cause printing 
to abort.  (If you haven't already done so take a look at <file://:Bad Tunes> for examples of common errors and how to 
fix them.)

¥       If you are running under Carbonlib in OS 8 or 9, make sure the program has enough memory, especially if you 
are using antialiasing, or if the file includes large tunes which extend over more than a page.

¥       Make sure that you have enough free space on your system disk.  BarFly writes lots of temporary files while 
assembling the pictures to send to the printer, and printing will fail if the disk fills up.   When using antialiasing this 
can amount to several hundred kb per page printed.

¥       If you are printing from multivoice abc, be sure to turn on the Align Voices option in the View menu (otherwise 
the program may place page breaks in between bracketed staves).

Setting up
By default, BarFly will scale the pictures to fill the printable area of the page.  When you print a tune book however, 
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you will want to increase the size of the margins, for aesthetic reasons, in order to make room for binding the pages 
and for the page numbers, if any.  Open up the Viewer Preferences dialog and click the Print OptionsÉ button.  

Margins
The first time you use this dialog, the values in the four margin setting text boxes represent the minimum margins - i.e. 
the width of the unprintable area around the edges of the page.  If you try to set the margins smaller than this the 
program will just quietly increase them again.  Something like a 1" margin all round will look right on A4 or US Letter 
size paper.  

Page numbers
If you want the pages numbered, you can opt to put the numbers at the top or at the bottom of the page, and either 
centred or alternately at the left and right margins.  By default, the page numbers start at 1, but you can set this to 
another value if the print run is a continuation.

Page breaks
You can set the program to print the tunes contiguously, so each tune follows on from the previous one, to start a new 
page whenever it encounters a tune which is too small to fit the available space (i.e. not to split a tune across a 
linebreak unless it's too big to fit on a single page) or to start a new page for every tune.

If you check the Enable Double-Sided Printing checkbox, you will get an extra dialog every time you print, in which 
you can select whether to print the even numbered pages, the odd numbered pages or both.

Checking the layout
With the window in split-screen mode, select the tunes you want to print from the index pane by command-clicking, 
shift-clicking or typing Command-Option-A to select all.  Next choose Print PreviewÉ from the File menu, and click 
the Print button in the dialog.  The program will then work its way through the file, scrolling each abc tune into the text 
pane as it does so.  Once the music pictures have been assembled into pages the program opens up a window with a 
much-reduced picture of the first page.  Clicking on the arrow buttons will take you to each page in turn so you can 
get an idea of how the pictures have been arranged, and if there are any problems.  Under OS X there is also a Preview 
button in the Print dialog, so you can also see a preview by selecting PrintÉ then hitting the Preview button.  In this 
case the preview is displayed in the Preview program and takes a little longer to appear, but has the advantage that you 
can magnify the pictures to see the details.

Most of the problems you are likely to encounter concern the placing of page breaks.  BarFly will always place page 
breaks between tunes, between staves in a tune or between lines of words if the music has words following the tune.  
However, if the spacing between staves is small, and the music contains leger lines, guitar chords or other symbols 
between the staves the page breaks may cut through them.  If this is the case, cancel the preview, go back to the 
Viewer Preferences dialog and decrease the number of staves per page to solve the problem.

While the program will always place page breaks between lines of words, it will not necessarily keep verses together.  
If this happens you can solve the problem by adding empty W: lines before the offending verse to push it onto the next 
page.  This is also a useful technique for increasing the amount of space between tunes even if they don't have words:  
you can add empty W: lines after any tune to increase the spacing between this tune and the next and push the 
following tunes down the page.

If the majority of the tunes look OK, but there are problems with one or two tunes which need different settings (a 
different spacing between the staves to deal with multiple lines of words, say) you can change the settings for a single 
tune by recording a different set of preferences in the abc.  To do this, cancel the preview, select the offending tune in 
the index, call up the Viewer Preferences dialog and make the necessary changes, inspecting the results with the Apply 
button.  When you have the settings right, click the Record button to record that set of preferences in a %%Bfly line in 
the abc, then exit the dialog using the Cancel button.  (If you hit OK, you will change the preferences for all of the 
tunes.)

If you want to look at a page in more detail than is available in the preview, you can save it as a picture.
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Print it!
When you are sure that everything is as you want it, you can either choose PrintÉ or click the Print button in the Print 
Preview window - the results are just the same.

PRINTING DOUBLE SIDED

If you have enabled double-sided printing in the Print Options dialog, each time you print you will be asked whether 
you want to print the odd-numbered, even-numbered or all pages.  To print double-sided, first print off the odd-
numbered pages.  Take the printed pages and put them back in the printer the opposite way round, so that they feed 
into the printer in the correct order and orientation.  Without changing any of the settings, print again, this time 
selecting to print the even numbered pages.  This will only work if your printer does not distort or crumple the paper 
on the first printing, and isn't too sensitive to misfeeds.

MAKING A TABLE OF CONTENTS

Finally, when you have printed out those five hundred tunes you will want to make a table of contents so you can look 
up the tune you want in your tune book.  BarFly cannot print the index;  however there is a sneaky way to export it as 
a text file.  From the File menu select Export>Tab-Delimited Text and select a place to save the file.  The program will 
ask you to enter a format string - enter "XT" (without the quotes).  Open the file again in BarFly and you will find a 
list of IDs and tune names in the order in which they were printed.  You will still have to add the page numbers by 
hand though.

PRINTING TO POSTSCRIPT OR PDF FILES

Under OS X 10.2 you can choose to create Postscript or PDF files directly from the Print dialog instead of printing.  In 
earlier versions of OS X you could do this by hitting the Preview button, then saving the resulting file from the 
Preview application.  Under Classic/Carbonlib
any postscript printer driver (e.g. Apple Lasewriter 8) can output a postscript file instead of sending it to the printer.  
You don't actually need to have a postscript printer to do this - just select Laserwriter 8 in the Chooser, and when you 
issue the Print command change the destination in the Print dialog from Printer to File.  There are also some Postscript 
file options available in the main options popup menu.  

Be aware though that BarFly does not use postscript symbols, and once converted to postscript or PDF they do not re-
size nicely.  In this case, therefore, you should not scale the image - leave the scale at 100%, and use the Viewer 
Preferences panel to make the music look good on screen.  You will get exactly the same image in the postscript file.

PDF  files can be created under Classic/Carbonlib if you have Adobe Distiller installed, by choosing Adobe PDF 
Writer in the Chooser, then printing as normal.  PDF is useful for giving pictures of music to people who use non-
Macintosh computers, since Adobe Acrobat Viewer is available for almost all platforms, and is free.  Again, when 
printing to a PDF file you should not scale the image, as this will result in a messy picture with distorted symbols and 
irregularly-spaced staff lines.  If you leave the scale at 100%, the music in the PDF file will look exactly as it does 
when viewed from within BarFly.

--------------------------------------------------------------------------------------------------------------------------------
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